Zypper Library Update

Missing Library Files for Zypper

Severity: Major

The following error is very important to steer-clear of because the only alternative I have found that will solve this problem once it occurs is to completely reinstall OpenSUSE 11.0. The error began when I was alerted that updates were available for installation and allowed my system to install the patches. The first error I received was a list of dependency errors (as follows)…

nothing provides libexiv2.so.4 needed by libkexiv2-3-0.1.7-15.i586
nothing provides libexiv2.so.4 needed by ufraw-0.13-52.i586
nothing provides libexiv2.so.4 needed by ufraw-gimp-0.13-52.i586
nothing provides yast2 >= 2.17.7 needed by yast2-installation-2.17.0-2.noarch
zvbi-0.2.30-3.i586 requires libzvbi.so.0, but this requirement cannot be provided
gconf2-branding-openSUSE-2.20-60.noarch requires desktop-data-openSUSE = 11.0, but this requirement cannot be provided
libtunepimp5-mp4-0.5.3-100.pm.9.i586 requires libtunepimp5 = 0.5.3-100.pm.9, but this requirement cannot be provided
zypper-0.11.9-0.1.i586 requires libzypp.so.424, but this requirement cannot be provided

The problem was compounded when I went to install a package in YaST Package Manager. I received the following error as I tried to install an unrelated package: click here. After some time of letting this problem go, I made the decision to downgrade Zypper. This worsened the problem as I now could not open any YaST Modules, such as Package Manager and LAN Connections. I got the following xmessage error…

Error while creating client module sw_single

The update for Zypper also had the dependency…

zypper-0.11.9-0.1.i586 requires libzypp.so.424, but this requirement cannot be provided

I downloaded the source files for libzypp.so.424 and moved them into the /usr/lib directory. This did not solve the problem. I was instructed to issue the command zypper sl in a terminal window to give a readout of the current repositories installed. After reinstalling OpenSUSE 11.0 (the second time, because I ran into this problem once, then reinstalled, and had it again, and reinstalled again), it was found that the error was caused by repository errors.

Solution

The error above is a known OpenSUSE problem, but is only caused by manually installing specific repositories. It was found that if Factory repositories, rather than 11.0 repositories, were added to YaST/Zypper, a dependency error would occur because the Factory repositories were not the same version as that of the operation system (OpenSUSE 11.0). The best way to keep this error from happening is to be sure that the repositories you add should be for version 11.0 (or your version of OpenSUSE) and not the Factory or another version of the repository.

Advertisements

~ by unseenghost on 15 Jul 2008.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: